为andorid安装AVD

    技术2022-05-12  0

    升级到ADK1.5后,启动模拟器会报错:

     

    Failed to find an AVD compatible with target 'Android 1.5'. Launch aborted.

    原来是需要安装Android Virtual Devices (AVDs)

     

    命令如下:

     

    android create avd -n <name> -t <targetID> [-<option> <value>] ...

    其中targetID选择有

     

    Available Android targets:id:1    Name: Android 1.1    Type: platform    API level: 2    Skins: HVGA (default), HVGA-L, HVGA-P, QVGA-L, QVGA-Pid:2    Name: Android 1.5    Type: platform    API level: 3    Skins: HVGA (default), HVGA-L, HVGA-P, QVGA-L, QVGA-Pid:3    Name: Google APIs    Type: add-on    Vendor: Google Inc.    Description: Android + Google APIs    Based on Android 1.5 (API level 3)    Libraries:    * com.google.android.maps (maps.jar)        API for Google Maps    Skins: HVGA (default), HVGA-L, QVGA-P, HVGA-P, QVGA-L

    详情可参考:http://developer.android.com/guide/developing/tools/avd.html


    最新回复(0)