Incompatible JVM问题

    技术2022-05-11  22

    原因: 

         运行eclipse出现以下错误:Incompatible JVM 的对话框,内容如下: Version 1.3.1_01 of the JVM is not suitable for this product.Version:1.4.1 or greater is required.一,系统上的JAVA JDK版本过低,去装高版本的JDK.二,这个是最有可能是装了oracle了,因为oracle是使用1.3JVM的而eclipse是需要1.4以上JVM的.

    解决方法:

    对于1:window -> preferences -> java -> installed jres 新建一个,并把这个指定为默认的就行了

    对于2:因为机子里装了oracle,oracle自带1.31版JDK,解决方法是在环境变量中的PATH里装你装的JDK1.42的路径写到oracle路径前面,这样系统就不会先找oracle的jdk1.31了  


    最新回复(0)